summaryrefslogtreecommitdiffstats
path: root/build-stage3.sh
diff options
context:
space:
mode:
authorKyle K <kylek389@gmail.com>2020-01-27 17:10:23 -0600
committerKyle K <kylek389@gmail.com>2020-01-27 17:10:23 -0600
commitf4f7b4ac910b7d74daf7524f86833ce242e9aaa1 (patch)
treea414285c8e08c00c426f0c6f726c05c6b381424a /build-stage3.sh
parent10976d5eac561ca712aac29d3f5e5f50988af390 (diff)
downloadgentoox-f4f7b4ac910b7d74daf7524f86833ce242e9aaa1.tar.gz
gentoox-f4f7b4ac910b7d74daf7524f86833ce242e9aaa1.tar.bz2
gentoox-f4f7b4ac910b7d74daf7524f86833ce242e9aaa1.zip
20200127 update
- provide script to build stage3 gcc graphite tarball - linux 5.5 - use zstd10 for ISO - enable UEFI booting
Diffstat (limited to 'build-stage3.sh')
-rwxr-xr-xbuild-stage3.sh36
1 files changed, 36 insertions, 0 deletions
diff --git a/build-stage3.sh b/build-stage3.sh
new file mode 100755
index 0000000..f073223
--- /dev/null
+++ b/build-stage3.sh
@@ -0,0 +1,36 @@
+#!/bin/bash
+
+version_stamp="$(date +%Y%m%d).graphite"
+
+if [[ ! -f .catalyst-prep-done ]]; then
+ builddate=$(wget --quiet -O - http://distfiles.gentoo.org/releases/amd64/autobuilds/current-stage3-amd64/ | sed -nr "s/.*href=\"stage3-amd64-([0-9].*).tar.xz\">.*/\1/p")
+ if [[ ! -f "stage3-amd64-$builddate.tar.xz" ]]; then
+ wget http://distfiles.gentoo.org/releases/amd64/autobuilds/current-stage3-amd64/stage3-amd64-$builddate.tar.xz
+ fi
+
+ (git clone https://github.com/gentoo/releng.git; cd releng; patch -p1 < ../0001-releng-gcc-add-graphite-support.patch)
+
+ mkdir -p /var/tmp/catalyst/builds/default
+ cp -v "stage3-amd64-$builddate.tar.xz" /var/tmp/catalyst/builds/default/stage3-amd64-latest.tar.xz
+ emerge --sync
+ catalyst -s latest
+ touch .catalyst-prep-done
+fi
+
+cp -v releng/releases/weekly/specs/amd64/stage{1,2,3}.spec .
+
+sed -i "s/version_stamp: latest/version_stamp: $version_stamp/" stage1.spec
+sed -i "s#@REPO_DIR@#$(pwd)/releng#g" stage1.spec
+sed -i "s/version_stamp: latest/version_stamp: $version_stamp/" stage2.spec
+sed -i "s/source_subpath: default\/stage1-amd64-latest/source_subpath: default\/stage1-amd64-$version_stamp/" stage2.spec
+sed -i "s#@REPO_DIR@#$(pwd)/releng#g" stage2.spec
+sed -i "s/version_stamp: latest/version_stamp: $version_stamp/" stage3.spec
+sed -i "s/source_subpath: default\/stage2-amd64-latest/source_subpath: default\/stage2-amd64-$version_stamp/" stage3.spec
+sed -i "s#@REPO_DIR@#$(pwd)/releng#g" stage3.spec
+
+catalyst -f stage1.spec
+catalyst -f stage2.spec
+catalyst -f stage3.spec
+
+cp -v /var/tmp/catalyst/builds/default/stage3-amd64-$version_stamp.tar.xz .
+