summaryrefslogtreecommitdiffstats
path: root/gentoox_build.sh
diff options
context:
space:
mode:
authorKyle K <kylek389@gmail.com>2020-04-10 17:12:17 -0500
committerKyle K <kylek389@gmail.com>2020-04-10 17:12:17 -0500
commit6a5b94da381d9a6d122d7a5e89f4991ff3deaf20 (patch)
tree99f54b8ee91e14f4b60138cd80f1d2695027fba2 /gentoox_build.sh
parentb4f174636480d159cea89905480bbd4cac6e1ec6 (diff)
downloadgentoox-6a5b94da381d9a6d122d7a5e89f4991ff3deaf20.tar.gz
gentoox-6a5b94da381d9a6d122d7a5e89f4991ff3deaf20.tar.bz2
gentoox-6a5b94da381d9a6d122d7a5e89f4991ff3deaf20.zip
update Linux to 5.6.3
Diffstat (limited to 'gentoox_build.sh')
-rwxr-xr-xgentoox_build.sh24
1 files changed, 13 insertions, 11 deletions
diff --git a/gentoox_build.sh b/gentoox_build.sh
index c9a53f8..0bba5ba 100755
--- a/gentoox_build.sh
+++ b/gentoox_build.sh
@@ -25,7 +25,7 @@ userpassword=gentoox
builddate="20200210.graphite"
#builddir="build-$(date +%Y%m%d)"
builddir="build-20200210"
-KERNEL_CONFIG_DIFF="0001-kernel-config-cfs-r3.patch"
+KERNEL_CONFIG_DIFF="0001-kernel-config-cfs-r4.patch"
binpkgs=/root/var/cache/binpkgs/
distfiles=/root/var/cache/distfiles/
@@ -164,6 +164,7 @@ sys-apps/kmod lzma
sys-kernel/linux-firmware initramfs redistributable unknown-license
x11-libs/libdrm libkms
media-libs/mesa d3d9 lm-sensors opencl -vaapi vdpau vulkan vulkan-overlay xa xvmc
+media-libs/libsdl2 gles2
www-client/firefox -system-libvpx hwaccel pgo lto wayland
dev-libs/boost python
dev-libs/boost python_targets_python3_7
@@ -205,19 +206,19 @@ if [[ ! -f '/tmp/gentoox-kernelpatches-applied' ]]; then
git clone https://github.com/graysky2/kernel_gcc_patch.git
wget --quiet https://gitlab.com/post-factum/pf-kernel/commit/cf7a8ad26e0bd6ca8afba89f53d2e9dc43ee2598.diff -O O3-always-available.diff
#wget --quiet -m -np -c 'ck.kolivas.org/patches/5.0/5.5/5.5-ck1/patches/'
- wget --quiet https://gitlab.com/sirlucjan/kernel-patches/raw/master/5.5/aufs-patches/0001-aufs-20200203.patch
- wget --quiet https://git.froggi.es/tkg/PKGBUILDS/raw/master/linux55-tkg/linux55-tkg-patches/0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
- wget --quiet https://git.froggi.es/tkg/PKGBUILDS/raw/master/linux55-tkg/linux55-tkg-patches/0002-clear-patches.patch
- wget --quiet https://git.froggi.es/tkg/PKGBUILDS/raw/master/linux55-tkg/linux55-tkg-patches/0006-add-acs-overrides_iommu.patch
- wget --quiet https://git.froggi.es/tkg/PKGBUILDS/raw/master/linux55-tkg/linux55-tkg-patches/0007-v5.5-fsync.patch
- wget --quiet https://git.froggi.es/tkg/PKGBUILDS/raw/master/linux55-tkg/linux55-tkg-patches/0011-ZFS-fix.patch
- wget --quiet https://gitlab.com/sirlucjan/kernel-patches/-/raw/master/5.5/wireguard-patches/0001-WireGuard-20200205.patch
+ wget --quiet https://gitlab.com/sirlucjan/kernel-patches/-/raw/master/5.6/aufs-patches/0001-aufs-20200302.patch
+ wget --quiet https://git.froggi.es/tkg/PKGBUILDS/raw/master/linux56-rc-tkg/linux56-tkg-patches/0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
+ wget --quiet https://git.froggi.es/tkg/PKGBUILDS/raw/master/linux56-rc-tkg/linux56-tkg-patches/0002-clear-patches.patch
+ wget --quiet https://git.froggi.es/tkg/PKGBUILDS/raw/master/linux56-rc-tkg/linux56-tkg-patches/0006-add-acs-overrides_iommu.patch
+ wget --quiet https://git.froggi.es/tkg/PKGBUILDS/raw/master/linux56-rc-tkg/linux56-tkg-patches/0007-v5.6-fsync.patch
+ wget --quiet https://git.froggi.es/tkg/PKGBUILDS/raw/master/linux56-rc-tkg/linux56-tkg-patches/0011-ZFS-fix.patch
+ #wget --quiet https://gitlab.com/sirlucjan/kernel-patches/-/raw/master/5.5/wireguard-patches/0001-WireGuard-20200205.patch
patch -p1 < kernel_gcc_patch/enable_additional_cpu_optimizations_for_gcc_v9.1+_kernel_v5.5+.patch
patch -p1 < O3-always-available.diff
#for f in ck.kolivas.org/patches/5.0/5.5/5.5-ck1/patches/*.patch; do patch -p1 < "\$f"; done
patch -p0 < ../$KERNEL_CONFIG_DIFF
- patch -p1 < 0001-aufs-20200203.patch
+ patch -p1 < 0001-aufs-20200302.patch
echo -e "CONFIG_AUFS_FS=y\nCONFIG_AUFS_BRANCH_MAX_127=y\nCONFIG_AUFS_BRANCH_MAX_511=n\nCONFIG_AUFS_BRANCH_MAX_1023=n\nCONFIG_AUFS_BRANCH_MAX_32767=n\nCONFIG_AUFS_HNOTIFY=y\nCONFIG_AUFS_EXPORT=n\nCONFIG_AUFS_XATTR=y\nCONFIG_AUFS_FHSM=y\nCONFIG_AUFS_RDU=n\nCONFIG_AUFS_DIRREN=n\nCONFIG_AUFS_SHWH=n\nCONFIG_AUFS_BR_RAMFS=y\nCONFIG_AUFS_BR_FUSE=n\nCONFIG_AUFS_BR_HFSPLUS=n\nCONFIG_AUFS_DEBUG=n" >> .config
sed -i "s/CONFIG_ISO9660_FS=m/CONFIG_ISO9660_FS=y/" .config
patch -p1 < 0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
@@ -226,7 +227,7 @@ if [[ ! -f '/tmp/gentoox-kernelpatches-applied' ]]; then
patch -p1 < 0007-v5.5-fsync.patch
patch -p1 < 0011-ZFS-fix.patch
patch -p1 < ../zfs-ungpl-rcu_read_unlock-export.diff
- patch -p1 < 0001-WireGuard-20200205.patch
+ #patch -p1 < 0001-WireGuard-20200205.patch
sed -i 's/CONFIG_DEFAULT_HOSTNAME="artixlinux"/CONFIG_DEFAULT_HOSTNAME="gentoox"/' .config
sed -i 's/CONFIG_LOCALVERSION=""/CONFIG_LOCALVERSION="-x86_64"/' .config
sed -i 's/CONFIG_NET_IP_TUNNEL=y/CONFIG_NET_IP_TUNNEL=m/' .config
@@ -382,7 +383,8 @@ x11-libs/libxshmfence abi_x86_32
x11-libs/libXv abi_x86_32
x11-libs/libXvMC abi_x86_32
x11-libs/libXxf86vm abi_x86_32
-media-libs/libglvnd abi_x86_32' >> /etc/portage/package.use/gentoox
+media-libs/libglvnd abi_x86_32
+virtual/opencl abi_x86_32' >> /etc/portage/package.use/gentoox
emerge -av steam-meta
touch /tmp/gentoox-steam-done
HEREDOC