summaryrefslogtreecommitdiffstats
path: root/patches/media-libs/gst-plugins-bad/gst-plugins-bad-1.14.5-make-fix.patch
diff options
context:
space:
mode:
authorKyle K <kylek389@gmail.com>2020-02-07 07:40:55 -0600
committerKyle K <kylek389@gmail.com>2020-02-07 07:40:55 -0600
commit8686b0be24da91d172bf4f1a0881608480c70d8c (patch)
tree7f3e2a5c156e0782706c3a15c23dc906dba58527 /patches/media-libs/gst-plugins-bad/gst-plugins-bad-1.14.5-make-fix.patch
parenta15e402f359a977403b0217d2bc2882ea3b3b675 (diff)
downloadgentoox-8686b0be24da91d172bf4f1a0881608480c70d8c.tar.gz
gentoox-8686b0be24da91d172bf4f1a0881608480c70d8c.tar.bz2
gentoox-8686b0be24da91d172bf4f1a0881608480c70d8c.zip
makefile fixes to gstreamer
Diffstat (limited to 'patches/media-libs/gst-plugins-bad/gst-plugins-bad-1.14.5-make-fix.patch')
-rw-r--r--patches/media-libs/gst-plugins-bad/gst-plugins-bad-1.14.5-make-fix.patch293
1 files changed, 293 insertions, 0 deletions
diff --git a/patches/media-libs/gst-plugins-bad/gst-plugins-bad-1.14.5-make-fix.patch b/patches/media-libs/gst-plugins-bad/gst-plugins-bad-1.14.5-make-fix.patch
new file mode 100644
index 0000000..bcc07b1
--- /dev/null
+++ b/patches/media-libs/gst-plugins-bad/gst-plugins-bad-1.14.5-make-fix.patch
@@ -0,0 +1,293 @@
+--- gst-plugins-bad-1.14.5.old/common/glib-gen.mak 2018-03-23 20:45:17.000000000 -0000
++++ gst-plugins-bad-1.14.5/common/glib-gen.mak 2020-01-25 02:59:25.736661871 -0000
+@@ -1,11 +1,13 @@
+ # these are the variables your Makefile.am should set
+ # the example is based on the colorbalance interface
+
++H := \#
++
+ #glib_enum_headers=$(colorbalance_headers)
+ #glib_enum_define=GST_COLOR_BALANCE
+ #glib_enum_prefix=gst_color_balance
+
+-enum_headers=$(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++enum_headers=$(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
+
+ # these are all the rules generating the relevant files
+ %-marshal.h: %-marshal.list
+diff -Naur gst-plugins-bad-1.14.5.old/common/gst-glib-gen.mak gst-plugins-bad-1.14.5/common/gst-glib-gen.mak
+--- gst-plugins-bad-1.14.5.old/common/gst-glib-gen.mak 2018-03-23 20:45:17.000000000 -0000
++++ gst-plugins-bad-1.14.5/common/gst-glib-gen.mak 2020-01-25 02:59:25.736661871 -0000
+@@ -1,14 +1,16 @@
+ # these are the variables your Makefile.am should set
+ # the example is based on the colorbalance interface
+
++H := \#
++
+ #glib_enum_headers=$(colorbalance_headers)
+ #glib_enum_define=GST_COLOR_BALANCE
+ #glib_gen_prefix=gst_color_balance
+ #glib_gen_basename=colorbalance
+ #glib_gen_decl_banner=GST_EXPORT
+-#glib_gen_decl_include=\#include <gst/foo/foo-prelude.h>
++#glib_gen_decl_include=$(H)include <gst/foo/foo-prelude.h>
+
+-enum_headers=$(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++enum_headers=$(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
+
+ # these are all the rules generating the relevant files
+ $(glib_gen_basename)-marshal.h: $(glib_gen_basename)-marshal.list
+diff -Naur gst-plugins-bad-1.14.5.old/ext/srt/Makefile.in gst-plugins-bad-1.14.5/ext/srt/Makefile.in
+--- gst-plugins-bad-1.14.5.old/ext/srt/Makefile.in 2019-05-29 17:00:09.000000000 -0000
++++ gst-plugins-bad-1.14.5/ext/srt/Makefile.in 2020-01-25 02:59:25.737661871 -0000
+@@ -17,12 +17,14 @@
+ # these are the variables your Makefile.am should set
+ # the example is based on the colorbalance interface
+
++H := \#
++
+ #glib_enum_headers=$(colorbalance_headers)
+ #glib_enum_define=GST_COLOR_BALANCE
+ #glib_gen_prefix=gst_color_balance
+ #glib_gen_basename=colorbalance
+ #glib_gen_decl_banner=GST_EXPORT
+-#glib_gen_decl_include=\#include <gst/foo/foo-prelude.h>
++#glib_gen_decl_include=$(H)include <gst/foo/foo-prelude.h>
+
+
+ VPATH = @srcdir@
+@@ -795,7 +797,7 @@
+ gstsrtserversink.h \
+ $(NULL)
+
+-enum_headers = $(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++enum_headers = $(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
+ all: all-am
+
+ .SUFFIXES:
+diff -Naur gst-plugins-bad-1.14.5.old/ext/srtp/Makefile.in gst-plugins-bad-1.14.5/ext/srtp/Makefile.in
+--- gst-plugins-bad-1.14.5.old/ext/srtp/Makefile.in 2019-05-29 17:00:09.000000000 -0000
++++ gst-plugins-bad-1.14.5/ext/srtp/Makefile.in 2020-01-25 02:59:25.737661871 -0000
+@@ -17,12 +17,14 @@
+ # these are the variables your Makefile.am should set
+ # the example is based on the colorbalance interface
+
++H := \#
++
+ #glib_enum_headers=$(colorbalance_headers)
+ #glib_enum_define=GST_COLOR_BALANCE
+ #glib_gen_prefix=gst_color_balance
+ #glib_gen_basename=colorbalance
+ #glib_gen_decl_banner=GST_EXPORT
+-#glib_gen_decl_include=\#include <gst/foo/foo-prelude.h>
++#glib_gen_decl_include=$(H)include <gst/foo/foo-prelude.h>
+
+ VPATH = @srcdir@
+ am__is_gnu_make = { \
+@@ -775,7 +777,7 @@
+ BUILT_SOURCES = gstsrtp-enumtypes.c gstsrtp-enumtypes.h
+ nodist_libgstsrtp_la_SOURCES = $(BUILT_SOURCES)
+ CLEANFILES = $(BUILT_SOURCES)
+-enum_headers = $(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++enum_headers = $(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
+ all: $(BUILT_SOURCES)
+ $(MAKE) $(AM_MAKEFLAGS) all-am
+
+diff -Naur gst-plugins-bad-1.14.5.old/ext/webrtc/Makefile.in gst-plugins-bad-1.14.5/ext/webrtc/Makefile.in
+--- gst-plugins-bad-1.14.5.old/ext/webrtc/Makefile.in 2019-05-29 17:00:09.000000000 -0000
++++ gst-plugins-bad-1.14.5/ext/webrtc/Makefile.in 2020-01-25 02:59:25.737661871 -0000
+@@ -17,12 +17,14 @@
+ # these are the variables your Makefile.am should set
+ # the example is based on the colorbalance interface
+
++H := \#
++
+ #glib_enum_headers=$(colorbalance_headers)
+ #glib_enum_define=GST_COLOR_BALANCE
+ #glib_gen_prefix=gst_color_balance
+ #glib_gen_basename=colorbalance
+ #glib_gen_decl_banner=GST_EXPORT
+-#glib_gen_decl_include=\#include <gst/foo/foo-prelude.h>
++#glib_gen_decl_include=$(H)include <gst/foo/foo-prelude.h>
+
+
+ VPATH = @srcdir@
+@@ -797,7 +799,7 @@
+
+ libgstwebrtc_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+ libgstwebrtc_la_LIBTOOLFLAGS = $(GST_PLUGIN_LIBTOOLFLAGS)
+-enum_headers = $(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++enum_headers = $(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
+ all: all-am
+
+ .SUFFIXES:
+diff -Naur gst-plugins-bad-1.14.5.old/gst-libs/gst/interfaces/Makefile.am gst-plugins-bad-1.14.5/gst-libs/gst/interfaces/Makefile.am
+--- gst-plugins-bad-1.14.5.old/gst-libs/gst/interfaces/Makefile.am 2018-03-23 20:45:15.000000000 -0000
++++ gst-plugins-bad-1.14.5/gst-libs/gst/interfaces/Makefile.am 2020-01-25 02:59:25.738661871 -0000
+@@ -5,13 +5,15 @@
+ headers_photography = \
+ photography.h
+
++H := \#
++
+ # variables used for enum/marshal generation
+ glib_enum_headers=$(headers_photography)
+ glib_enum_define=GST_PHOTOGRAPHY
+ glib_gen_prefix=gst_photography
+ glib_gen_basename=photography
+ glib_gen_decl_banner=GST_PHOTOGRAPHY_API
+-glib_gen_decl_include=\#include <gst/interfaces/photography-prelude.h>
++glib_gen_decl_include=$(H)include <gst/interfaces/photography-prelude.h>
+
+ built_sources = \
+ photography-enumtypes.c
+diff -Naur gst-plugins-bad-1.14.5.old/gst-libs/gst/interfaces/Makefile.in gst-plugins-bad-1.14.5/gst-libs/gst/interfaces/Makefile.in
+--- gst-plugins-bad-1.14.5.old/gst-libs/gst/interfaces/Makefile.in 2019-05-29 17:00:10.000000000 -0000
++++ gst-plugins-bad-1.14.5/gst-libs/gst/interfaces/Makefile.in 2020-01-25 02:59:25.738661871 -0000
+@@ -17,12 +17,14 @@
+ # these are the variables your Makefile.am should set
+ # the example is based on the colorbalance interface
+
++H := \#
++
+ #glib_enum_headers=$(colorbalance_headers)
+ #glib_enum_define=GST_COLOR_BALANCE
+ #glib_gen_prefix=gst_color_balance
+ #glib_gen_basename=colorbalance
+ #glib_gen_decl_banner=GST_EXPORT
+-#glib_gen_decl_include=\#include <gst/foo/foo-prelude.h>
++#glib_gen_decl_include=$(H)include <gst/foo/foo-prelude.h>
+
+
+ VPATH = @srcdir@
+@@ -773,7 +775,7 @@
+ glib_gen_prefix = gst_photography
+ glib_gen_basename = photography
+ glib_gen_decl_banner = GST_PHOTOGRAPHY_API
+-glib_gen_decl_include = \#include <gst/interfaces/photography-prelude.h>
++glib_gen_decl_include = $(H)include <gst/interfaces/photography-prelude.h>
+ built_sources = \
+ photography-enumtypes.c
+
+@@ -805,7 +807,7 @@
+ $(built_headers)
+
+ CLEANFILES = $(BUILT_SOURCES)
+-enum_headers = $(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++enum_headers = $(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
+ all: $(BUILT_SOURCES)
+ $(MAKE) $(AM_MAKEFLAGS) all-am
+
+diff -Naur gst-plugins-bad-1.14.5.old/gst-libs/gst/mpegts/Makefile.am gst-plugins-bad-1.14.5/gst-libs/gst/mpegts/Makefile.am
+--- gst-plugins-bad-1.14.5.old/gst-libs/gst/mpegts/Makefile.am 2018-03-23 20:45:15.000000000 -0000
++++ gst-plugins-bad-1.14.5/gst-libs/gst/mpegts/Makefile.am 2020-01-25 02:59:25.738661871 -0000
+@@ -39,6 +39,8 @@
+ $(GST_ALL_LDFLAGS) \
+ $(GST_LT_LDFLAGS)
+
++H := \#
++
+ glib_enum_headers=gstmpegtssection.h \
+ gstmpegtsdescriptor.h \
+ gst-atsc-section.h \
+@@ -50,7 +52,7 @@
+ glib_gen_prefix=gst_mpegts
+ glib_gen_basename=gstmpegts
+ glib_gen_decl_banner=GST_MPEGTS_API
+-glib_gen_decl_include=\#include <gst/mpegts/mpegts-prelude.h>
++glib_gen_decl_include=$(H)include <gst/mpegts/mpegts-prelude.h>
+
+ BUILT_SOURCES = gstmpegts-enumtypes.c gstmpegts-enumtypes.h
+ nodist_libgstmpegts_@GST_API_VERSION@_la_SOURCES = gstmpegts-enumtypes.c
+diff -Naur gst-plugins-bad-1.14.5.old/gst-libs/gst/mpegts/Makefile.in gst-plugins-bad-1.14.5/gst-libs/gst/mpegts/Makefile.in
+--- gst-plugins-bad-1.14.5.old/gst-libs/gst/mpegts/Makefile.in 2019-05-29 17:00:10.000000000 -0000
++++ gst-plugins-bad-1.14.5/gst-libs/gst/mpegts/Makefile.in 2020-01-25 02:59:25.739661871 -0000
+@@ -17,12 +17,14 @@
+ # these are the variables your Makefile.am should set
+ # the example is based on the colorbalance interface
+
++H := \#
++
+ #glib_enum_headers=$(colorbalance_headers)
+ #glib_enum_define=GST_COLOR_BALANCE
+ #glib_gen_prefix=gst_color_balance
+ #glib_gen_basename=colorbalance
+ #glib_gen_decl_banner=GST_EXPORT
+-#glib_gen_decl_include=\#include <gst/foo/foo-prelude.h>
++#glib_gen_decl_include=$(H)include <gst/foo/foo-prelude.h>
+
+
+
+@@ -821,7 +823,7 @@
+ glib_gen_prefix = gst_mpegts
+ glib_gen_basename = gstmpegts
+ glib_gen_decl_banner = GST_MPEGTS_API
+-glib_gen_decl_include = \#include <gst/mpegts/mpegts-prelude.h>
++glib_gen_decl_include = $(H)include <gst/mpegts/mpegts-prelude.h>
+ BUILT_SOURCES = gstmpegts-enumtypes.c gstmpegts-enumtypes.h
+ nodist_libgstmpegts_@GST_API_VERSION@_la_SOURCES = gstmpegts-enumtypes.c
+ CLEANFILES = $(BUILT_SOURCES) $(am__append_1)
+@@ -841,7 +843,7 @@
+ @HAVE_INTROSPECTION_TRUE@gir_DATA = $(BUILT_GIRSOURCES)
+ @HAVE_INTROSPECTION_TRUE@typelibsdir = $(libdir)/girepository-1.0/
+ @HAVE_INTROSPECTION_TRUE@typelibs_DATA = $(BUILT_GIRSOURCES:.gir=.typelib)
+-enum_headers = $(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++enum_headers = $(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
+ all: $(BUILT_SOURCES)
+ $(MAKE) $(AM_MAKEFLAGS) all-am
+
+diff -Naur gst-plugins-bad-1.14.5.old/gst-libs/gst/webrtc/Makefile.am gst-plugins-bad-1.14.5/gst-libs/gst/webrtc/Makefile.am
+--- gst-plugins-bad-1.14.5.old/gst-libs/gst/webrtc/Makefile.am 2018-03-24 17:44:06.000000000 -0000
++++ gst-plugins-bad-1.14.5/gst-libs/gst/webrtc/Makefile.am 2020-01-25 02:59:25.738661871 -0000
+@@ -1,11 +1,13 @@
+ lib_LTLIBRARIES = libgstwebrtc-@GST_API_VERSION@.la
+
++H := \#
++
+ glib_enum_headers = dtlstransport.h icetransport.h rtptransceiver.h webrtc_fwd.h
+ glib_enum_define = GST_WEBRTC
+ glib_gen_prefix = gst_webrtc
+ glib_gen_basename = webrtc
+ glib_gen_decl_banner=GST_WEBRTC_API
+-glib_gen_decl_include=\#include <gst/webrtc/webrtc_fwd.h>
++glib_gen_decl_include=$(H)include <gst/webrtc/webrtc_fwd.h>
+
+ built_sources = webrtc-enumtypes.c
+ built_headers = webrtc-enumtypes.h
+diff -Naur gst-plugins-bad-1.14.5.old/gst-libs/gst/webrtc/Makefile.in gst-plugins-bad-1.14.5/gst-libs/gst/webrtc/Makefile.in
+--- gst-plugins-bad-1.14.5.old/gst-libs/gst/webrtc/Makefile.in 2019-05-29 17:00:11.000000000 -0000
++++ gst-plugins-bad-1.14.5/gst-libs/gst/webrtc/Makefile.in 2020-01-25 02:59:25.739661871 -0000
+@@ -17,12 +17,14 @@
+ # these are the variables your Makefile.am should set
+ # the example is based on the colorbalance interface
+
++H := \#
++
+ #glib_enum_headers=$(colorbalance_headers)
+ #glib_enum_define=GST_COLOR_BALANCE
+ #glib_gen_prefix=gst_color_balance
+ #glib_gen_basename=colorbalance
+ #glib_gen_decl_banner=GST_EXPORT
+-#glib_gen_decl_include=\#include <gst/foo/foo-prelude.h>
++#glib_gen_decl_include=$(H)include <gst/foo/foo-prelude.h>
+
+
+
+@@ -761,7 +763,7 @@
+ glib_gen_prefix = gst_webrtc
+ glib_gen_basename = webrtc
+ glib_gen_decl_banner = GST_WEBRTC_API
+-glib_gen_decl_include = \#include <gst/webrtc/webrtc_fwd.h>
++glib_gen_decl_include = $(H)include <gst/webrtc/webrtc_fwd.h>
+ built_sources = webrtc-enumtypes.c
+ built_headers = webrtc-enumtypes.h
+ BUILT_SOURCES = $(built_sources) $(built_headers)
+@@ -806,7 +808,7 @@
+ $(GST_ALL_LDFLAGS) \
+ $(GST_LT_LDFLAGS)
+
+-enum_headers = $(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++enum_headers = $(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
+ @HAVE_INTROSPECTION_TRUE@BUILT_GIRSOURCES = GstWebRTC-@GST_API_VERSION@.gir
+ @HAVE_INTROSPECTION_TRUE@gir_headers = $(patsubst %,$(srcdir)/%, $(libgstwebrtc_@GST_API_VERSION@include_HEADERS))
+ @HAVE_INTROSPECTION_TRUE@gir_sources = $(patsubst %,$(srcdir)/%, $(libgstwebrtc_@GST_API_VERSION@_la_SOURCES)) $(BUILT_SOURCES)